PDA

View Full Version : I think I need some help


Mikejuh
09-23-2007, 12:40 PM
Yo, as the title says, I have a problem.

A few days ago my harddisk in my box failed on me, no real backups or what so ever. Ok, new linux, cod2 files copying, mod files, reconfiging the scriptdata. Ok good to go.

All starts fine, but after about 6 to 10 hours, the server crashes. The proces is still there in linux but it just hangs in the middle of a map. connection interrupted.
There is no specific time or map bound to the error,,, no certain amount of players, one time with as little as 5 players, other time with 20.

Things already tried, headpopping off, punkbuster off, map packs out, soundaliases folder, not a gamestate error.

It just hangs, stays at connection interrupted. It doesnt write to the log anymore, if i go to the console log, the last things written in there, was about 5 minutes ago.



Could it be something about linux updates available?

I use a .sh startscript with a simple command line: ./cod2_lnxded_1.3 +set fs_game K4F1 +set fs_homepath "logs" +exec codserver.cfg +set dedicated 2 +set sv_punkbuster 1 +map_rotate &


Bad memory?
Hunkmegs at 512 mb, I do not think that the memory is full because of the mod already.

I use serverwatch for monitoring the server, I've had it off, no luck.


The mod is ww2x 6.3 linux only, no others. 6 map packs.

p.s.
Howdy wildcard

superman
09-25-2007, 03:42 PM
Hi, I was wondering,
What linux are you using?
Is this just a shelled box linux,
or a full fledge linux operating system?

Are you using old linux kernals?

I'm sure you know what your doing,
but unfortunately, I don't know much about
the COD2 versus linux and I would love
to learn more about that.

I just had a few questions:

Are you keeping track of the temperature in
your case? Is your computer overheating?

- What Logging options are yours set to in CFG?

For example:


// Log Settings
set g_logsync "?" // 0=no log, 1=buffered, 2=continuous, 3=append
set logfile "?" // 0 = NO log, 1 = log file enabled
set g_log "?" // Name of log file, default is games_mp.log
set sv_log_damage "?"


- What is your localized message for linux option set to?

For example:


//************************************************** ************************************************** *******
// ADMINS ATTENTION!!!! -- WINDOWS SERVERS SHOULD HAVE THIS COMMENTED OUT!!!!!
// LINUX SERVERS MUST USE 1 OR 2 !!!!!!
// This setting allows you to control the localized string messages spam messages in the console log a bit.
// If set to 1 then less names are shown...thus less spam (warning messages) in the console log.
// If set to 2 then more names are shown...thus more spam (warning messages) in the console log.
// 0 = off (windows servers only), 1 = less spam, 2 = more spam, default = 0
//************************************************** ************************************************** ********
set wwx_is_linux "?"


- Please Also recheck your map rotation line for errors.

- Could be a setting in the CFG's that could be causing conflicts.
(You would need to go through each setting?)

- What do you have your : Obituary Messages set at:
(set wwx_obituary "?")

Sorry I Couldn't be any help,
Marc would be a much better help.

Good Luck.

Mikejuh
09-26-2007, 02:17 PM
The temps are fine, around 40 degrees celcius. I'm using debian 4.0, about the latest updates so that should be good?

I tried loggin buffered and continous, do not log damage.


About the localized, I'm using ww2x 6.3, I think there is no option for the localized spam issue...

I'm using option 4 in 6.3, which is as follows:
// 4 = stock obituary with stats!, personal sound and personal messages, I do not use the fancy message stuff.

Maybe option 2 would be something to try out.
Head popping off, but unfortunately the logs do not show any errors cause the log is not finished, it just stops in the middle of a line.


Could it be something with the amount of memory? The hunkmegs are set at 512, Maybe that amount is full after a certain amount of time and it just hangs. Was there a bug in 6.3?? If you are ingame at the very last moment before the crash, the screen states connection interrupted and disappears a few times. Only a matter of seconds before it fully hangs.



I do not think marc is going to reply in this thread ever during his life. With his baby and the past about his own server. Things out there went crazy so our ways were seperated.


But i'm sure there is someone who can maybe help me out :)

Thanks,
Mike

superman
09-26-2007, 02:54 PM
Ok, so let me just check real quick,
I'm not sure what the difference between 1.6.3 linux
versus
the 1.8b Multi OS version for ww2x.

I believe that there has been a major change
between the ww2x v1.6.3 linux to v1.8b multi OS.

The v1.8b Multi OS seems to work pretty well,
you might try that version instead, if you haven't already.

Some of the things that you mentioned show that your
probably still using v1.6.3 linux ww2x.

However, I'm not sure if you meant that your using the
v1.8b Multi OS with the 1.6.3 linux derivative code.

So, I got confused there from your posts, but
please consider downloading the latest v1.8b ww2x Multi OS mod, if you
haven't already. Please let us know.

Here's the link, don't use the windows installer, obviously... LOL.

This should contain both the Linux and windows version in the zip file combined into one mod.

http://forums.raidersmerciless.com/showthread.php?t=1591

Please post here, if you are already using that version.

Mikejuh
09-26-2007, 03:06 PM
No, i'm using 6.3, with 6.3 configs lol. Last time i tried to update it did not work at the first shot so i went back to 6.3 in seconds. I will reconfig everything and see if that fixes anything.

From now on i will use the iwd unpacked on serverside.


altough i hope wildcard comes up with some solution. Be a man man.

Marc.
09-30-2007, 08:15 AM
lol, my server doesn't have a "past" ...there is a "past" from you and some others on my server.

Now you go "be a man man" ???... i see your still not changed your attitude and still try to provoke me after all the other shit you tried to pull at me?..let alone the threats you made?

and now you come here to seek my help?....o well i guess that's just your age, 15 is a rebellious age.

Ok, enough of that tho...bad blood or not this can have something to do with the mod (altho i doubt it) so it can affect others as well...so if there is a solution we need to find it.

First of all let me make clear that the versions on this site are slightly different then on wildcards ...the difference is the ranking system, the downloads here give 13 ranks with 5 ranksymbols, the wildcards one gives 8 ranks with 8 insignia.

Not that this would affect anything else tho...but just to make certain who uses what mod

Secondly the 1.8b version is way more stable then 1.6.3...altho that version didn't have any crash issues also.

I do recommend the 1.8b version tho....apart from the huge localisation text message issues it fixes (less spam in console ....certainly for windows servers)..it has numerous tiny updates in code..so therefore possibly the one that stops your server from crashing ...IF the crash is mod related.

To hunt down the cause of a crash if its mod related i need script runtime errors, without those its searching for a needle in a haystack.

Since you cant find those i suggest you zip up the entire mod and cfg files and send them to me so i can test the hell out of it.

perhaps you edited stuff you weren't supposed to....or did it wrong...who knows....cant tell without seeing it.

it also can be an OS issue, i don't run debian 4 i still use 3.1 which is rock solid for me.......if it ain't broken don't fix it.
1.6.3 and 1.8b never crashed on debian 3.1 , the only time the servers were down is when i rebooted them to create a new game log (every saturday night)...or to do a hardware reboot every 3 months or so....or a inbetween modupdate.

so since i never had crash issues on debian 3.1 with 1.6.3 or 1.8b and you don't have runtime errors to show me...i suggest to zip up your version and send it to me so i can test it .....or upgrade to 1.8b.

Mikejuh
09-30-2007, 10:53 AM
I suppose you rent your server? That would be much easyer yes.


=

I get no script errors in the logs, only thing i did yesterday was download the games_mp log and rename it while the server was running. Before that it was running since thursday. Could that be the cause of the last crash this afternoon?

Altough i do not think that it could be debian 4.0, maybe i should try 3.1 or another one.


First i ran obituary at 4, sounds messages and stats, now on 1 and it seemed much more stable.

,,,
I might forgot something, i installed debian, webmin and the map with the cod2 server. Run it with a start.sh line and thats all. Might have updated gcc library but that's it.



* btw, im 16 now. I cannot help it what that old retarted clan did to you.

Mikejuh
09-30-2007, 12:27 PM
trying 1.8b now. :B

Mikejuh
10-02-2007, 04:55 PM
I tried 1.8b, no luck, crashed 5 minutes ago, I think its faulty memory or the wrong kernel.

Mikejuh
10-03-2007, 03:53 PM
Now i do get runtime errors, for 3 days i still got crashes with 1.8b.

My linux is deiban 4.0, newest kernel, downloades a .deb for some gcc library if i can remember correctly. Webmin and cod server nothing more nothing less.

Did i forgot something? Wrong gcc library, wrong kernel, bad memory????? I will try debian 3.1 r5 this week. New ram.

Here are the runtime errors im getting now, i did not get these the last days.

******* script runtime error *******
undefined is not a field object: (file 'maps/mp/gametypes/_weapons.gsc', line 160)
if(level.weapons[weaponindex].allow) self dropItem(weapon);
*
called from:
(file 'maps/mp/gametypes/_weapons.gsc', line 121)
if(clipsize1 || reservesize1) self dropItemIfAllowed(weapon1);
*
called from:
(file 'maps/mp/gametypes/tdm.gsc', line 357)
self maps\mp\gametypes\_weapons::dropWeapon();
*
called from:
(file 'maps/mp/gametypes/_spawnlogic.gsc', line 759)
[[level.spawnlogic_oldCallbackPlayerKilled]](
*
called from:
(file 'maps/mp/gametypes/_callbacksetup.gsc', line 69)
[[level.callbackPlayerKilled]](eInflictor, eAttacker, iDamage, sMeansOfDeath, sWeapon, vDir, sHitLoc, timeOffset, deathAnimDuration);
*
called from:
(file 'maps/mp/gametypes/_callbacksetup.gsc', line 66)
CodeCallback_PlayerKilled(eInflictor, eAttacker, iDamage, sMeansOfDeath, sWeapon, vDir, sHitLoc, timeOffset, deathAnimDuration)
*
called from:
(file 'maps/mp/gametypes/tdm.gsc', line 288)
self finishPlayerDamage(eInflictor, eAttacker, iDamage, iDFlags, sMeansOfDeath, sWeapon, vPoint, vDir, sHitLoc, psOffsetTime);
*
called from:
(file 'ww2x/_wwx_main.gsc', line 893)
[[level.wwx_orignalPlayerDamage]](eInflictor, eAttacker, iDamage, iDFlags, sMeansOfDeath, sWeapon, vPoint, vDir, sHitLoc, psOffsetTime);
*
called from:
(file 'maps/mp/gametypes/_callbacksetup.gsc', line 59)
[[level.callbackPlayerDamage]](eInflictor, eAttacker, iDamage, iDFlags, sMeansOfDeath, sWeapon, vPoint, vDir, sHitLoc, timeOffset);
*
started from:
(file 'maps/mp/gametypes/_callbacksetup.gsc', line 56)
CodeCallback_PlayerDamage(eInflictor, eAttacker, iDamage, iDFlags, sMeansOfDeath, sWeapon, vPoint, vDir, sHitLoc, timeOffset)
*
************************************

******* script runtime error *******
cannot cast undefined to bool: (file 'maps/mp/gametypes/_weapons.gsc', line 160)
if(level.weapons[weaponindex].allow) self dropItem(weapon);
*
called from:
(file 'maps/mp/gametypes/_weapons.gsc', line 121)
if(clipsize1 || reservesize1) self dropItemIfAllowed(weapon1);
*
called from:
(file 'maps/mp/gametypes/tdm.gsc', line 357)
self maps\mp\gametypes\_weapons::dropWeapon();
*
called from:
(file 'maps/mp/gametypes/_spawnlogic.gsc', line 759)
[[level.spawnlogic_oldCallbackPlayerKilled]](
*
called from:
(file 'maps/mp/gametypes/_callbacksetup.gsc', line 69)
[[level.callbackPlayerKilled]](eInflictor, eAttacker, iDamage, sMeansOfDeath, sWeapon, vDir, sHitLoc, timeOffset, deathAnimDuration);
*
called from:
(file 'maps/mp/gametypes/_callbacksetup.gsc', line 66)
CodeCallback_PlayerKilled(eInflictor, eAttacker, iDamage, sMeansOfDeath, sWeapon, vDir, sHitLoc, timeOffset, deathAnimDuration)
*
called from:
(file 'maps/mp/gametypes/tdm.gsc', line 288)
self finishPlayerDamage(eInflictor, eAttacker, iDamage, iDFlags, sMeansOfDeath, sWeapon, vPoint, vDir, sHitLoc, psOffsetTime);
*
called from:
(file 'ww2x/_wwx_main.gsc', line 893)
[[level.wwx_orignalPlayerDamage]](eInflictor, eAttacker, iDamage, iDFlags, sMeansOfDeath, sWeapon, vPoint, vDir, sHitLoc, psOff

Hope you can do anything with them.

Thanks

Mikejuh
10-12-2007, 06:08 PM
Oh man, it was the localized english file, 1 was not in place. :confused:

Mikejuh
10-22-2007, 04:03 PM
Ok, im having problems again, yesterday updated the stats, removed the games_mp.log, restarted.

Tomorrow it crashed, this evening it crashed.

The log again just hangs, the server hangs, connection interrupted.
No errors in the log, process is still running.


What could it be this time? to high gamestate would cause runtime errors in the log, any ideas?

Thanks,
Mike